'getDefaultForGlobal' undeclared at installing root 5.14 +


(I am working at an SLC3 machine)

I wanted to install the new root-version. First I tried to update my source to the
HEAD-version and do ‘make’, but it didn’t work. I tried as well to download the source from the ‘recommended’ version (5.14.00b) but I experienced the same problem
(although I deleted the whole root-tree to be sure to not have any interferences of some dependencies.

When doing ‘make’ I get the following error-messages (for both versions I tried)

g++ -O -pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -DR__CASTOR2 -I/usr/include/shift -o castor/src/TCastorFile.o -c castor/src/TCastorFile.cxx
In file included from castor/src/TCastorFile.cxx:53:
/usr/include/shift/RfioTURL.h:68:39: stager_client_commandline.h: No such file or directory
/usr/include/shift/RfioTURL.h:127:1: warning: “/" within comment
/usr/include/shift/RfioTURL.h:138:1: warning: "/
” within comment
/usr/include/shift/RfioTURL.h:158:1: warning: “/*” within comment
castor/src/TCastorFile.cxx: In member function int TCastorFile::ParseAndSetGlobal()': castor/src/TCastorFile.cxx:290:getDefaultForGlobal’ undeclared (first use
this function)
castor/src/TCastorFile.cxx:290: (Each undeclared identifier is reported only
once for each function it appears in.)
make: *** [castor/src/TCastorFile.o] Error 1
832.070u 47.020s 18:11.90 80.5% 0+0k 0+0io 205597pf+0w[/quote]

I don’t know how to proceed to get rid of this problem. Any hint is very welcome :wink:

Thanks for your help

You have an old version of libshift. Make sure you get the latest version.

Cheers, Fons.


I looked at the versions of libshift I have on my computer. It seems, that I have got the newest one.
I have looked again into the root install manual and searched through the CERN computing helpdesk,
and there is sometimes mentioned a file called libshift.a which is told to be a static library.

as I have the version of libshift.so, I suppose that libshift.a is the problem. Could you give me an advice how I get the libshift.a - file,… (if it is really the one I need).

I tried as well replacing the file /usr/lib/libshift.a by the one from an lxplus-machine. But it didn’t change the outcome.

Thanks for your help,

is there a solution to this compilation problem that i am also experiencing using SLC4?
could you tell which version of libshift one needs to download.
many thanks, nabil .

Dear all,

I am running into the same problem that you mention here, i checked the libraries, and i get the same as you:
lrwxrwxrwx 1 root root 19 Jan 19 04:07 /usr/lib/libshift.so.2.1 -> libshift.so. (etc)

I work with Scientific Linux CERN SLC release 4.5 (Beryllium).

… but i couldn’t find an answer on the forum, did anyone manage something ?



Please try with the version 2.1.1-9. I use this version to build ROOT binaries for LCG.