Geometry editor : mixture material


I started the geometry editor in order to create some volume with different materials

The problem is that I can’t use the button which allows to create a [color=red]new mixture of materials [/color]

Do you have any ideas how to solve this ?



Ismail, this is not yet implemented, as few other editors missing at the moment. We will implement them in some time from now.


Hi Andrei,

I want to add my own classes in TGeoManagerEditor.cxx, (or in the root hierarchy)

The problem is when I create a new class in the TGeoManagerEditor.cxx and I compile (command: make), it compiles all the ROOT classes.

As you have seen my TGeoManagerEditor.cxx, I only added variables and methods in the TGeoManagerEditor.h, and when I compile, it compiles only these modified files, so why it compiles all the ROOT when I add new classes :frowning: ?

Is there a way to add classes with compiling only modified files ?

Thanks in advance, Ismail

Ismail, first of all, modifying directly TGeoManagerEditor in the way you intend will work only for your own version - as I told you tracking stuff makes the object of a different GUI. For the mixture part, this was implemented by Mihaela and it is already in CVS. The current framework imposes certain rules and the most important one is that for each editable class one has to implement a separate GUI like: ClassNameEditor.

Now, in your exercise you might have touched other headers than TGeoManagerEditor.h - I don’t know - but of course simply the change of TGeoManagerEditor will not trigger recompilation of all root…


Hi Andrei,

I have this error in the execution after adding a sequence of XML instructions in the TGeoManagerEditor.cxx

[color=darkred]/home/user/root/bin/root.exe: symbol lookup error: /home/user/root/lib/ undefined symbol: _ZN10TXMLEngineC1Ev[/color]

It seems an error that concern the root installation or configuration
(It’s not a syntaxic error)

Have you any Ideas about this error or should I send you the code ?

Thanks in advance
Regards Ismail

Hi Ismail,

Try: configure --enable-xml --with-xml-incdir=… --with-xml-libdir=…