Garfield++ TrackHeed/Garfroot Issues

I’m trying to run a simple simulation with Garfield++ (software just updated, but the problem occurred before as well), but I can’t seem to include any object of the Garfield::TrackHeed class without inducing the following error when running the program (which compiles just fine):

    Generator type: TRandom3
    Seed: 1361387185
alpha(20786) malloc: *** error for object 0x13c9e1ae0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

The error occurs even when I write a program as simple as

#include "TrackHeed.hh"

using namespace std;

int main()
     Garfield::TrackHeed *heed = new TrackHeed();
     return 0;

I also tried making garfroot (which also compiles just fine using the makefile provided on the Garfield++ webpage). The same error occurs whenever I try starting garfroot. I’m running on Mac 10.8. I’m probably missing something pretty fundamental, but I’m at wit’s end. Any help would be much appreciated!


If you still encounter this problem, I recommend you try running your example with valgrind to pin point the issue (but it was likely a incompatible build issue)


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.