Home | News | Documentation | Download

Garfield ++ example

Hi i installed Garfield using the link
http://garfieldpp.web.cern.ch/garfieldpp/getting-started/
Now i am trying to run Gem example using the same link
At the very last step i got this error(see screenshot)

After the cmake command, did you do make? Type make after you do cmake. It looks like you just did cmake and then called the gem executable, but that doesn’t exist until after the make command.

When i typed make command after cmake command than a fatal error occurred(see screenshot).

I also encountered this problem in the past, but I am not sure if what you are experiencing is the same as what I did. For my case, it seemed like Garfield was having problems looking for ROOT libraries, so I needed to add a couple of things when I run CMake (btw, this is the instruction that I followed to install Garfield – http://garfieldpp.web.cern.ch/garfieldpp/getting-started/). On the instruction page, when you run CMake, the command that is provided is:

cmake [-DCMAKE_INSTALL_PREFIX=<installdir>] [-DWITH_DOCS=ON] [-DWITH_EXAMPLES=ON] $GARFIELD_HOME

For my case, I used that with two extra options:

cmake -DCMAKE_INSTALL_PREFIX=/home/khang/garfield/install -DWITH_DOCS=ON -DWITH_EXAMPLES=ON -DROOT_INSTALL_DIR=/home/khang/Cern_Root/root-6.20.02/root-install/include -DROOT_LIBRARY_DIR=/home/khang/Cern_Root/root-6.20.02/root-install/lib $GARFIELD_HOME

This fixes my problem at the time and I haven’t encountered this specific problem anymore after that.

Hi,
I understood from this thread that your problem has been solved?

Yes It is solved

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.