Garfield++: can't find error while loading shared libraries

I am a beginner for garfield++ and just tried to install garfield++ on my SLC6 pc. I followed the installation guide. If I use make, then I always got the error when I install Garfroot: undefined reference to `Garfield::ViewGeometry::Class()’. I searched the forum and find a couple of threads talking about this problem, but none of them solved the problem in my machine. I also found that my code crashed whenever I tried to use ViewGeometry or ViewSignal.
I then tried to use cmake to generate the libraries, now I don’t have compile or link errors when I compile GarfRoot or my other codes, but the executable program can’t run any more and I always get the error: error while loading shared libraries: cannot open shared object file: No such file or directory.
The is acutally in $(GARFIELD_HOME)/Library, but the program can’t find it.
Can anyone tell me how to solve the problem? Thank you very much!

Make sure that the “$(GARFIELD_HOME)/Library” directory is present in your “LD_LIBRARY_PATH” environment variable.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.