Function BIT(0) is not defined in current scope with VC10


I installed Root 5.32 on Windows 7 using “root_v5.32.00.win32.vc10.msi”. I have VC10 C++ Express.
When I try to run some code I get the following:

root [1] .x neuro_graphical.cpp
Warning: Re-initialization ignored const kNone C:\root/include\GuiTypes.h(90)
Warning: Re-initialization ignored const kCopyFromParent C:\root/include\GuiTypes.h(91)
Warning: Re-initialization ignored const kParentRelative C:\root/include\GuiTypes.h(92)
Error: Function BIT(0) is not defined in current scope C:\root/include\GuiTypes.h(141)
*** Interpreter error recovered ***

This code worked previously in ROOT on a MAC. I don’t know if the problem is with the way ROOT is installed on this machine, or with the code or with something else. Any ideas on what might be going on?

Thank you.


Can you provide the minimum script reproducing the problem?


I attached a script that sets up root to display the simulation. The simulation isn’t part of this attached code, but i think this code should still work. When i run this code (root[0] .x test.cpp) it still gives me the same error.

test.cpp (3.97 KB)


The problem has been fixed in the trunk (revision 42929) and you can work around the problem by using:#ifdef __CINT__ #define ROOT_GuiTypes 0 #endifearly on in your script.


That has resolved the problem for me. Thank you so much! :smiley: