Fscanf parameter[0]=0

Hi all,
I’m a student at his first contact with root.
I’ve installed the framework via .msi pack on Windows 8.
I tried to run a simple helloworld message and other C stuff, and worked fine. Also tried some specific roots’ commands, and everything worked fine. All people around me, who doesn’t seems to know that win version has been put out, said that was amazing and funny. But…
I tried to run a data analysis macro previously created by my team. In this code there are some fscanf functions that give me the following error:

fscanf param[0]=0 must not be 0

than breaks.
This macro works opening several files (first one goes perfect, file opening not a problem) and searching for a specific tag in the text of the file opened. The text found before the tag is loaded into an array, then processed.
The macro works fine on Mac and Linux machines, so I think there’s some issue about file using permission, but I can’t get over this by my self.
Thank you in advance for your support!

solved: sprintf doesn’t accepts relative path. I had to add the entire path where to find files and everything worked perfectly on windows. =D>