FFTW not included in binaries


I have installed ROOT 6.04/02 .When I try to use RooFFTConv I get

Error in <TUnixSystem::FindDynamicLibrary>: FFTW[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /home/turra/root/lib:/home/turra/root/lib:.:/home/turra/root/lib:/lib64/tls/x86_64:/lib64/tls:/lib64/x86_64:/lib64:/usr/lib64/tls/x86_64:/usr/lib64/tls:/usr/lib64/x86_64:/usr/lib64
Error in <TVirtualFFT::FFT>: handler not found

it seems that something is not installed.


could you give some more details on the environment you are using, e.g. which OS are you using?


sorry: I am using fedora 20.

I believe you’ve been hit by the same issue as reported here:
RooFit error: <TVirtualFFT::FFT>: handler not found

So you have to install it locally. I’ll investigate whether that was not in by intention or by mistake.


How did you install ROOT? Did you take the binaries from root.cern.ch/content/release-60402 ? If yes, can you use a newer version? FTTW was included as builtin from 6.06.X with the option ‘builtin_fftw3’

thank you. I will do it

Hi, I hope it’s okay to reopen this topic. I have the same problem. For example when I try to run the FFT tutorial I get the error

Processing FFT.C... Error in <TMacOSXSystem::DynamicPathName>: FFTW[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /Users/kxg023/alicesw/aliphysics/master/inst/lib:/Users/kxg023/alicesw/aliroot/master/inst/lib:/Users/kxg023/alicesw/aliroot/master/inst/lib/tgt_macosx64:/Users/kxg023/alicesw/alien/api/lib:/Users/kxg023/alicesw/aliphysics/master/inst/lib:/Users/kxg023/alicesw/aliroot/master/inst/lib:/Users/kxg023/alicesw/aliroot/master/inst/lib/tgt_macosx64:/Users/kxg023/alicesw/geant3/v2-0/inst/lib/tgt_macosx64:/Users/kxg023/alicesw/geant3/v2-0/inst/lib:/Users/kxg023/alicesw/geant3/v2-0/inst/lib64:/Users/kxg023/alicesw/root/alice_v5-34-30/inst/lib:/Users/kxg023/alicesw/alien/api/lib::.:/Users/kxg023/alicesw/root/alice_v5-34-30/inst/lib::/Users/kxg023/alicesw/root/alice_v5-34-30/inst/lib/cint/cint/stl Error in <TVirtualFFT::FFT>: handler not found Error: illegal pointer to class object hm 0x0 6105 FFT.C:95: *** Interpreter error recovered ***
I am using ROOT v5-34-30 and OSX, but I also have the same error using Linux.
How did you fix the problem? Did you reinstall ROOT, or install the FFTW library separately and then link it somehow? I am quite new to ROOT so I’ll probably need step-by-step instructions! Thanks!

We were taking about ROOT-6. With the latest version of ROOT-6 the problem is solved.

Ah sorry I didn’t see the distinction.
I don’t believe I want ROOT -6 (I want to be compatible with AliRoot).
I will post a new topic. Thanks.

Dear KLGraham,
For ROOT 5, you will need to build yourself the binaries enabling fftw3 option (with -Dfftw3=ON). See the instructions at root.cern.ch/building-root