Fatal error when starting up ROOT for the first time

Please read tips for efficient and successful posting and posting code

ROOT Version: 6.22.00 and 6.18.04
Platform: Windows 10
Compiler: Command Prompt?


I installed ROOT version 6.22.00 as well as the Cmake, Visual Studio 2019, and the latest version of Python as instructed, but when I go to command prompt and try to run ROOT in an empty folder, it gives me the following error:

RegOpenKeyEx(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\$VERSION\InstallationFolder): returned 2: The system cannot find the file specified.
input_line_1:1:10: fatal error: 'new' file not found
#include <new>
Assertion failed: OldBuilder->DeferredDeclsToEmit.empty() && "Should have emitted all decls deferred to emit.", file C:\build\ws\BUILDTYPE\Debug\LABEL\windows10\V\6-18\root\interpreter\llvm\src\tools\clang\lib\CodeGen\ModuleBuilder.cpp, line 139

I also made sure to include ROOT in the path for all users when installing. After struggling with this for a while with version 6.22.00, I uninstalled and tried the same thing with version 6.18.04 and got the same error.

Thanks in advance for your help.

Try to start from a x86 Native Tools Command Prompt for VS 2019