Fails to load dynamic libs in $ROOTSYS/test

I am using root (5.16 and 5.15) for the first time, that is to say, I am learing to use root, and checking out some of the tutorials. I tried the games.C script, and I get the error:

dlopen error: /usr/root/test/ undefined symbol: _ZTV7TPoints
Load Error: Failed to load Dynamic link library /usr/root/test/
*** Interpreter error recovered ***

Well, this is not so important, since I don’t really need to play tetris or look at the Aclock, but I explored a bit more and I don’t have success loading any of the dynamic libs for games.C, i.e. Aclock, Hello, Tetris, from the command line in root, though TBench and libEvent don’t return an error. This happens on SL4-x86 and OS X-PPC. Is this a known problem with these shared libs? Maybe there is something broken with my install(s) of root?

Is your LD_LIBRARY_PATH containing $ROOTSYS/lib and $ROOTSYS/test ?


[quote=“brun”]Is your LD_LIBRARY_PATH containing $ROOTSYS/lib and $ROOTSYS/test ?


Yes, adding $ROOTSYS/test to LD_LIBRARY_PATH, and to DYLD_LIBRARY_PATH for the OS X, was the first thing I tried. I have now just gotten root 5.17 to build on Ubuntu Linux for PPC, and here it is working fine (I did not add $ROOTSYS/test the LD_LIBRARY_PATH for that one, but the others were broken in the same way both before and after adding it). The messages are slightly different between SL4 and OS X. The OS X version tells me:

I’ve tried deleting Aclock.o,, etcetera, from $ROOTSYS/test, and doing make again for them, but still same error. I do get different compiler output for the two systems as well, when remaking Aclock for example:


For SL4:

g++ -O -Wall -fPIC -I/urs/root/include -c Aclock.cxx
g++ -shared -O Aclock.o AclockDict.o -o
This version of ROOT has no thread support, threads not built

This issue has been fixed, for all platforms, in 5-17-02, it was broken in 5-15 and 5-16.

– Fons

[quote=“rdm”]This issue has been fixed, for all platforms, in 5-17-02, it was broken in 5-15 and 5-16.

– Fons[/quote]

OK, thanks, I’ll re-install then, using 5-17-02.