Failed to Install ROOT, pyROOT, matplotlib in Python3 in Mac OS

_ROOT Version:6.12.04
_Platform:MacOS Sierra 10.12.6
_Compiler:gcc 4.2.1

My goal is to upgrade my python from python 2.7 to python 3.x. For the purpose of data analysis, I want the following to work in python 3:
ROOT, pyROOT, root_numpy, and matplotlib
Though matplotlib is not part of ROOT, but it is essential for anyone who would like to do analysis with pyROOT.
And one important issue: my work computer doesn’t not give me sudo access. So I have to install everything in local path. And I prefer installing them via some package controls. I have tried homebrew, pyenv, anaconda, and all of them will make one of above not working:

  1. For homebrew, it cannot install earlier version of python. The default one is python 3.7, and the earliest one I can find by brew log python is 3.6.x. However, root_numpy has only been tested up to 3.5.
  2. For pyenv, matplotlib cannot run by the standard pyenv install 3.5.0 installation. One must do “enable-framework” so that matplotlib will work. However, by doing so, it requires sudo access to /Applications, which I don’t have. This path is hard-coded into the configure file, not trivial to change it. The issue can be found here:
  3. For anaconda, I have tried, and the problem is here: PyROOT with Anaconda Python 3.6 with ROOT 6.12.04 In short, there is no apparent answer on how to install pyROOT against python by Anaconda.

The only path forward I can see is to install python 3.5 directly from python website without package control software, which doesn’t seem like a great practice to me. Is there anything else that I can do?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.