Failed to build root on ubuntu 20.04, with or without xrootd

I’m trying to (re)install root v6.26/02 from source (due to a gcc upgrade). Using the cmake line from 6.22 failed as building xrootd failed. Once with a compilation error and once due to failing to download. Being unaware of any need for xrootd, I tried building without using

cmake ../root-6.26.02/ -DCMAKE_INSTALL_PREFIX=~/programs/ROOT/v6.26.02 -DCMAKE_CXX_STANDARD=17 -DCMAKE_CXX_FLAGS=-march=native -DCMAKE_C_FLAGS=-march=native -Dxrootd=OFF -Dbuiltin_xrootd=OFF -Dqt=OFF -Dbuiltin_gsl=ON -Dminuit2=ON -Droofit=ON -Dunuran=ON -Dpython3=ON -DPYTHON_EXECUTABLE=/usr/bin/python3.8 -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 -DPYTHON_LIBRARY=/usr/lib/python3.8/config-3.8-x86_64-linux-gnu/

But this fails with a cmake error:

-- Enabled support for:  asimage builtin_clang builtin_cling builtin_ftgl builtin_gl2ps builtin_glew builtin_gsl builtin_llvm builtin_nlohmannjson builtin_openui5 builtin_tbb builtin_unuran builtin_vdt builtin_xxhash builtin_zstd clad dataframe davix exceptions fftw3 gdml http imt mathmore mlp minuit2 opengl pyroot roofit webgui root7 rpath runtime_cxxmodules shared ssl tmva tmva-cpu tmva-pymva spectrum unuran vdt x11
-- Configuring done
CMake Error at CMakeLists.txt:518 (add_dependencies):
  The dependency target "NetxNG" of target "modules_idx" does not exist.

-- Generating done

Any ideas how to move forward from here?

(before installing ROOT I made sure all the required packages for Ubuntu are installed a-la Dependencies - ROOT, upgraded all packages, and rebooted)

You need to either delete CMakeCache.txt (and fully reconfigure) or edit this file to remove all mentions of NetxNG from modules_idx_deps variable.

I edited the file to remove the only such mention.
Worked like a charm, thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.