Error with VCRUNTIME140.lib

Hi, I have used Root on Windows 10 with visual studio until july and everything was fine. Now I need to use it again but when I try to launch a program I have this error:
LINK : fatal error LNK1181: it is not possible to open input file ‘VCRUNTIME140.lib’.

How can I correct this error?


I suppose the error comes when you use ACLiC, right? This should be fixed soon. You can still build by hand for the time being

I don’t know if I use ACLiC, I use Visual Studio Community 2019. Hovewer how can I build by hand ?

So can you tell me exactly when the error message appears?

Well, it depends what you want build… Let’s find out what you are doing first

The error message appears from the Developer Command Prompts for VS 2019. I write root and then .x NameFile.C++ and it gives me that error

OK, so you are using ACLiC (the ++ at the end of NameFile.C). Don’t worry, I’m working on it and it should be fixed soon (today).

Thank you. Have I to install something when you will fix it? Or do something else?

You can either:

  • wait for the next release (6.20 - around November-December)
  • wait for the next nightly build (tomorrow)
  • build ROOT from source

And BTW, you can also try to run your macro without compiling it, i.e. without the ++ at the end: .x NameFile.C

It is strange because until two months ago I work with root without problem using the same programs, visual studio and root …

I agree, this is very strange…

I have tried with only one +. I have the same error …

one + (ACLiC): compile if something has changed
two + (ACLiC): compile unconditionally

As I said, try without compiling it (without any +):

.x NameFile.C

without + everything is fine

1 Like

Hi @bellenot, is the problem fixed? I have a simple question, if I don’t compile everything ok… but what is the difference between compiling and not, and the risks of not compiling

Yes, the problem is fixed in the master. And there is no risk of not compiling the code (it is compiled by the JIT anyway)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.