Error with root installation

Hi, i installed root today on my new pc with fedora 40 and passed to the new pc from the old one all the codes.
Whenever i try fitting something, it returns this error:
“Warning in ROOT::Math::FitConfig::CreateMinimizer: Could not create the Minuit2 minimizer. Try using the minimizer Minuit”

To exclude incompatibility with my older codes, i tried doing a simple code:

TF1 *f = new TF1(“f”, “[0]”, 0, 100)
TH1F *h = new TH1F(“h”, “h”, 100, 0, 100)
The error still remains and is the same: this should exclude incompatibility with my old codes.

I installed the root package via terminal with
sudo dnf install root
I tried also doing root-config --features and minuit2 is there.
Thank you for your patience.

ROOT Version: 6.30/06
Platform: Fedora 40
Compiler: Not Provided


Welcome to the Root community and thank you for your patience!
We do not control that packaging, unfortunately. Is it an option for you to build from sources?


The Fedora package is splitting up root in several subpackages:

Did you install root-minuit2?

Hi! Actually this morning while trying to fix up the thing i tried different alternative methods, for example building from sources or compiled binaries.
While trying to build from sources, some errors while trying to make the build were encountered (during make -j8 it breaks).
While trying to build from compiled binaries, i encountered there some errors due to some dependencies (for example the tbb version of 2021 was missing the library (no clue why) and that breaks root, one has to switch to the tbb 2020.3 version).

In the end i gave up on those two option and switched back to the package manager and tried the following:
sudo dnf install root python3-root root-minuit2
And that did indeed the job, however i am having still some errors: like while trying to call a macro with the extension cpp++ it returns the error
Warning in cling::IncrementalParser::CheckABICompatibility():
Possible C++ standard library mismatch, compiled with GLIBCXX ‘20240411’
Extraction of runtime standard library version was: ‘20240507’

I believe this may be due to some other missing packages, i am now trying to find the right packages while seeing the list sent by jonas.

Thanks for the answers! I’ll let you know soon if everything works out fine

EDIT: maybe it’s not due to missing packages, maybe it’s due to the compiler i’m trying to understand what’s off