Error while compiling

Hello all,

I have a macro that I used to compile with
root> .L glfit.cpp++

This always worked fine, but today I wanted to compile the old macro again and I got the following error:

root [5] .L glfit.cpp++
Info in : creating shared library /afs/
In file included from /afs/,
from /afs/
/afs/ In function
void histgl(TH1F**, const char*, double, double)': /afs/ warning: unused parameterTH1Fh’
/afs/ warning: unused
parameter const char*sh' /afs/ warning: unused parameterDouble_t width’
/afs/ warning: unused
parameter Double_t sigma' In file included from /afs/, from /afs/ /afs/ In functionvoid histgl(TH1F
, const char*, double, double)’:
/afs/ warning: unused
parameter TH1F**h' /afs/ warning: unused parameterconst char*sh’
/afs/ warning: unused
parameter Double_t width' /afs/ warning: unused parameterDouble_t sigma’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.3/…/…/…/crt1.o(.text+0x18): In function _start': : undefined reference tomain’
collect2: ld returned 1 exit status

Can anybody please tell me what is suddenly wrong? I didn’t change the macro since the last time when it still worked. I also tried to use a newer version of Root (5.10.00e) but without succes.

Many thanks in advance for any help!


PS: File is attached
glfit.cpp (8.02 KB)


this is strange - ACLiC fails building the library, but it doesn’t report any errors (the “main” error comes from the “let’s find out what’s wrong” stage - you can ignore it). Is the library successfully built, and ACLiC just confused? Or did you run out of AFS space? Is the file / dir writable? Try to copy a file about the same size as the lib you’re trying to build to /afs/ to make sure…

If all that fails, set gDebug=7 on a root prompt before doing “.L glfit.cpp++”, and try to execute the command that ACLiC will now prompt one by one on a shell, to check which one fails. Maybe that gives a hint; otherwise please post the result of these checks, so we can have another look.



I think I found the problem: The library was already loaded by Root when I tried to compile it. I think this produced the error!

And you were right - the library was successfully built although there was the error message.

Thanks a lot for your help Axel!