Error when trying to run the compiler

source /cvmfs/
cmake .
make -j8

For while, everything is good and the executable ./build is done. The problem is, after i run ./build on terminal, i got this problem:

Heed: Could not retrieve database path.
ExAtomPhotoAbsCS::ExAtomPhotoAbsCS(...) const: ERROR:
cannot open file /shelllist.dat
FunNameStack: s_init=1 qname=1
  0  ExAtomPhotoAbsCS::ExAtomPhotoAbsCS(...) const 
File is /build/jenkins/workspace/lcg_release_pipeline/build/projects/Garfield++-HEAD/src/Garfield++/HEAD/Heed/heed++/code/PhotoAbsCS.cpp , line number is 1042
spexit_action: the streams will be now flushed
spexit_action: the abort function is called```

What could it be?

Sorry, I’m a bit lost. If you want to use the installation of Garfield++ from cvmfs the following should work:

source /cvmfs/
source /cvmfs/

As I said in my previous reply, I would however recommend to build the project yourself to make sure you have the latest version (there have probably been a few bug fixes since the snapshot of Garfield++ that was included in LCG 101).

1 Like

Again, you have solved my problem indirectly haha. I have just used the first source, didn’t know about the second one.

Now the build works as well :stuck_out_tongue:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.