Home | News | Documentation | Download

Error when build Root on Subsystem linux

I have a error when building the ROOT on subsystem linux.


I run command sudo apt install cmake again but it doesn’t resolve the problem.

ROOT Version: 6.18.04
Platform: Subsystem linux
Compiler: Not Provided


And there are some notifications when i run additional commands.

Can you access the internet from WSL? The errors are from failing to download the packages.

I can access the internet from WSL because i downloaded ROOT on WSL. I have a confuse. Do I need install Microsoft Visual Studio on Win 10 corresponding with version of ROOT installed on WSL?

Can you install other software using apt-get?