Error shows on running ROOT after installing in windows 10

Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

I am a user of windows 10 and i have been getting following error on running ROOT after installation. The windows closes after few seconds without a prompt. There is no unusual prompt whilst installation either.
I have tried various old/new debugged/regular version but the result seems to be the same. Following I’m pasting the messages displayed when root run is attempted.

RegOpenKeyEx(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\$VERSION\InstallationFolder): returned 2: The system cannot find the file specified.
RegOpenKeyEx(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Kits\Installed Roots\KitsRoot10): returned 2: The system cannot find the file specified.
input_line_1:1:10: fatal error: 'new' file not found
#include <new>
Assertion failed: OldBuilder->DeferredDeclsToEmit.empty() && "Should have emitted all decls deferred to emit.", file C:\build\ws\BUILDTYPE\Debug\LABEL\windows10\root\interpreter\llvm\src\tools\clang\lib\CodeGen\ModuleBuilder.cpp, line 139

This is likely due to using a different version of Visual Studio than the one ROOT was compiled with. Please make sure that you have the exact same version installed and that problem should go away.

I am using Windows 10 Pro and I had to install Microsoft Visual Studio 2019 separately as I did not find visual cpp preinstalled as previous versions of windows. Though I don’t think there’s any version for 2019 on the site. I tried the latest available version.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.