Error message when running stress test 5


I’ve just built a patched version of Root 5.14 using the head of the branch v5.14.00-patches in the ROOT CVS repository, on windows with VS 2003 with cygwin, as described here:

except I used VS 2003, and had some additional configuration flags:

./configure win32 --enable-roofit --enable-minuit2 --enable-table
–enable-python --disable-odbc --enable-gdml
–enable-unuran --enable-xrootd

All seems fine, I’ve also built the stress.exe in the test directory via the call:
nmake /f Makefile.win32 CFG=“Release”

All the tests return OK, however there is an error message reported with test 5:
Test 5 : Test graphics & Postscript… Error in TPluginHandler::SetupCallEnv: class TUtil3D not found in plugin Graf3d

Looking back at my build, I do see the TUtil3D.o file and it appears in the libGraf3D.def file.

Is this something to be concerned about? Should I suspect my build was somehow in error?



The class TUtil3D should be present in 5.14. We removed it in 5.15.
Are you sure that you do not mix 5.15 and 5.14 in your PATH ?
Did you run “make map” during the installation?


Hi Rene,

I didn’t do make map (should I?), I just did:
make install

To be sure, I just downloaded the v5.14.00d tag from the CVS repository and started fresh. I haven’t attempted to download v5.15 or the head of the repository (at least not on purpose). I obtained the v5.14.00d tag as follows:
cvs -d export -r v5-14-00d root

and then built via cygwin after resetting my ROOTSYS and clearing my PATH to be sure no other versions of ROOT remained - I do have v5.10.00 on my machine as well. Running stress again, produced the same result with an error message for test 5, concerning TUtil3D. I’m hoping I haven’t grabbed the wrong version of the code.

Take care,

Hi Heather,

Yes, please run “make map” and verify also that you don’t have a custom .rootrc file remaining from other ROOT version.
I will try 5.14.00d asap and let you know.


Hi Bertrand,

I tried make map and checked to be sure I don’t have a .rootrc being picked up. The error message persists, unfortunately. I look forward to hearing how your build of v5.14.00d and running stress turns out.


Hi Heather,

Ok, I see the problem. It shows up only with nmake, and not with make, so I didn’t see the problem before…
This has been fixed in CVS head, thanks to have reported the problem.
And for the time being, you can take Makefile.win32 in attachment.

Makefile.win32.txt (13.8 KB)

Hi Bertrand,
Thanks for the new Makefile - actually I still have some trouble. I see the addition of libNet.lib and libRIO.lib to ROOTLIBS and after my ROOT build, I do not have either of those, so my build of the test programs with this new Makefile fails. I’ve tried to follow the typical win32 configuration as much as possible when running ./configure - you can see my ./configure call in my first post. What would I need to do to force the creation of those libraries?

Maybe this isn’t so terribly important…I can try building stress.exe in cygwin with make and then the resulting stress.exe completes all its tests without any errors.


Ah…Actually, I just removed the libNet and libRIO and reran nmake - now the stress application completes with no error messages. Great!


Ooops! sorry, I gave you the version 5.15.03 :blush:
Anyway, you found how to solve the problem :wink: