Error message: The sequence of actions to read memberwise

I get a strange error message when I try to read back a data structure from a TTree stored in a root file:

Fatal in <ApplySequence>: The sequence of actions to read TVector3:3 member-wise was not initialized. aborting #0 0x000000325f2aa77e in waitpid () from /lib64/ #1 0x000000325f23e329 in do_system () from /lib64/ #2 0x00007f73ef963618 in TUnixSystem::StackTrace() () from /usr/local/root/lib/root/ #3 0x00007f73ef8ad504 in DefaultErrorHandler(int, bool, char const*, char const*) () from /usr/local/root/lib/root/ #4 0x00007f73ef8acc71 in ErrorHandler () from /usr/local/root/lib/root/ #5 0x00007f73ef8acda3 in Fatal(char const*, char const*, ...) () from /usr/local/root/lib/root/ #6 0x00007f73eea483a7 in TStreamerInfoActions::ReadLoopInvalid(TBuffer&, void*, void const*, TStreamerInfoActions::TConfiguration const*) () from /usr/local/root/lib/root/ #7 0x00007f73eea061d8 in TBufferFile::ApplySequenceVecPtr(TStreamerInfoActions::TActionSequence const&, void*, void*) () from /usr/local/root/lib/root/ #8 0x00007f73ef913643 in TClonesArray::Streamer(TBuffer&) () from /usr/local/root/lib/root/ #9 0x00007f73eea3c2ae in TKey::ReadObjectAny(TClass const*) () from /usr/local/root/lib/root/ #10 0x00007f73eea14b68 in TDirectoryFile::GetObjectChecked(char const*, TClass const*) () from /usr/local/root/lib/root/ #11 0x000000000043559a in Analyzer::ProcessAnalysis() () #12 0x0000000000431b33 in main () Abandon (core dumped)
The story behind it:
I have a program which writes instances,in the constructor of class A I get the error message above when I try to access data stored in the tree.

I’m afraid we need a macro which reproduces this problem (i.e. a minimal running example).

I work by the ROOT CERN data analysis software.
I have a macro file in the program that I use,
Then the story is written as:
I run the command by the executable of the program I set in following the path in the what I want stored the output root
the command is like this,

therefore qd I want to open the root file I get the error described before.
When I run the command to run the scan file to create two file, then the simulation root file is completely empty.
Thanks in advance.

I’m afraid you need to ask the author(s) of the “executable” why it fails.