Error Message of Running ROOT remotely with Cygwin X11

I’m working at home using XP as my workstation and my X11 client is Cygwin X.

The very first time I ran ROOT remotely from the Linux server in my office, it worked fine. But after that, it hasn’t worked since. All the remote X application can run normally. And actually, ROOT shows its startup window in my local X and the batch mode terminal but after that, whatever I do, even hitting the “return”, it will give an error message:

Error in : BadAccess (attempt to access private resource denied) (XID: 58, XREQ: 102)

I tried both 4.00/08 and 4.03/02. Also, I tried different X Window mangers except GNOME or KDE. But they all give same error and do nother further. However, ROOT 3.05 on another server works with my Cygwin X11.

But when I use my Apple laptop running Apply X11, any ROOT runs just fine.

What are special about Cygwin X11 and ROOT 3.05? What could be wrong? Why was the very first time OK? Thanks a lot for your help!

there’s probably something wrong with your x11 cygwin server. Check /tmp/XWin.log, if that doesn’t give any insight, try re-installing the cygwin xorg packages, and afterward posting to the cygwin mailing list ( or something). I cannot reproduce this, and I’ve not heard of it yet, so it’s almost impossible for me to track this down.

In your $ROOTSYS/etc/system.rootrc file could you replace
X11.FindBestVisual: yes
X11.FindBestVisual: no


Thanks for you guys’ replies!

First, I checked /tmp/XWin.log but saw nothing suspicious so I re-installed xorg package but the Error message persists.

Then, I modified my ROOT configuration on the Linux server from “X11.FindBestVisual: yes” to “X11.FindBestVisual: no”. But the Error is still there.

Another strange thing I found is Putty works fine. What I mean is I run the Cygwin/X server but not using its terminal, instead, I use Putty as my terminal connecting to my Linux server, and ROOT works fine.

So, it is not my local X11 server but the terminal or the SSH I’m using?

I believe I read something about an incompatibility with newer openssh versions and X11 forwarding - in which it’s a combination of the sshd on the machine you’re running root on, and the cygwin openssh you’re exporting your display to. Try googling on that, or ask the cygwin mailing list.

According to the discussion of … rorhandler
I think it is valuable to try "ssh -Y " not “ssh -X” for X11 forwarding.
I successfully soloved my problem like the situation experiednced by weiswang, however, I do not know why the difference of option of ssh
causes the problem.

Best regards

My situation
local : Linux(Vine linux 3.1)
remote : Linux, FreeBSD 5.1-RELEASED

see explanation at the CYGWIN FAQ … forwarding