Error in <TVirtualFFT::FFT>: plugin not found

Dear all,

I want to run RooFit, I run on lxplus, and I get the error and segmentation violation.

Error in TVirtualFFT::FFT: plugin not found
Error in TVirtualFFT::FFT: plugin not found
Error in TVirtualFFT::FFT: plugin not found

*** Break *** segmentation violation

It crushes on these lines

RooFFTConvPdf model("model","truth (X) gaussian", M, f1, dGauss); model.fitTo(data,Save(true),Hesse(true),Minos(false)) ;

Could you please tell me what I miss?
Any help is more than welcome!

Which installation of ROOT are you using in lxplus? What which root says?

The root version is 5.34/32 (heads/v5-34-00-patches@v5-34-30-102-g626b950

“which root” says /usr/bin/root

Is this what you mean?

The system installed version of ROOT should not be used. It’s rather old and it does not include any optional component. You need a version that was built with ‘fftw3’ enabled. Unfortunately the standalone binaries we provide do not include it (we will enable it for the next releases).
Meanwhile you can use the binaries we build for the LHC experiments in the context of the LCG releases. A new way to use them is to setup the an environment like this:

source /afs/

This version includes ROOT 6.04/14. If you need ROOT 5, there is a version having 5.34/24.

source /afs/

Thank you Mato! That solved my problem!

Dear co-rooters,

I am also trying to perform a simple FFT transformation using the installed version on lxplus and I get the same error.

I tried to use the binaries proposed by @mato but my access is denied.

Any idea on how to use the FFT interface?

Thanks in advance!