Error in <TTreeCache::FillBuffer>: Inconsistency

Using RDataFrame, I get errors of the form:

Error in <TTreeCache::FillBuffer>: Inconsistency: fCurrentClusterStart = xxx fEntryCurrent = yyy fNextClusterStart = zzz but fCurrentEntry should not be in between the two

Is this something to worry about, and if so, how can it be fixed?

ROOT Version: 6.14
Platform: SLC6
Compiler: GCC 7.3

Which exact version of ROOT do you have?

6.14/03. Specifically, the dev4 LCG release (it’s the only one that is built with C++ 17 support).

The fix (commit 4d05469146) has been pushed to the v6-14-00-patch branch today (8/21/18) and I assume we appear shortly (days) in the build you are using.

The commit is in today’s build, but I still get the error.

Can you share a reproducer so we can fix your case too?

1 Like

I can point you to the code:

It seems to be related to the multiple file support, since I don’t get this error if I run one file at a time.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.