Error in running root with screen on lxplus

Hi everybody, it’s my first post, hope I’m writing in the correct section.

I need to perform a long-running task using root on lxplus. In order to avoid connection problems I decided to run it using screen. This worked a couple of months ago but now I get an error.
I change directory to my workspace:

[fiemmi@lxplus068 ~]$ cd path/to/workdir

open a screen session:

[fiemmi@lxplus068 data2016]$ screen

and try to run root into the screen window:

[fiemmi@lxplus068 data2016]$ root -l

I get:

root: /usr/lib64/ version `CXXABI_1.3.8’ not found (required by root)

I can run root outside screen without issues. I don’t understand the error and I am not able to solve it alone.

Thank you very much for your help,


ROOT Version: 6.06/01
Platform: lxplus
Compiler: gcc version 5.3.0

If you sourced any script to get ROOT, you have to do it from inside the screen session. Do you source the LCG or other script from within screen?

Hi @amadio, thanks for your reply. Indeed I sourced some CMS software before opening a screen session. If I perform the source within screen everything works. Solved!

Thank you,


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.