Error in during compile

I am attempting to compile from the ROOT Git repository commit ID :

I have used the following command to configure and make the code:

cmake sourceDir -Droofit=ON -Dminuit2=ON -Dsoversion=ON -Dcxx11=ON && make -j3

I am compiling the code with gcc 5.1.0 under ArchLinux, with kernel 4.0.4-2. The compilation fails when trying to process the file. I am using Python 3.4.3 as the system default. The error message follows.

[ 52%] Generating etc/dictpch/allLinkDefs.h, etc/dictpch/allHeaders.h, etc/dictpch/allCppflags.txt
  File "root/build/unix/", line 413
    print "\nGenerating PCH for %s\n" %" ".join(modulesList)
SyntaxError: invalid syntax
CMakeFiles/onepcm.dir/build.make:152: recipe for target 'etc/dictpch/allLinkDefs.h' failed
make[2]: *** [etc/dictpch/allLinkDefs.h] Error 1
CMakeFiles/Makefile2:359: recipe for target 'CMakeFiles/onepcm.dir/all' failed
make[1]: *** [CMakeFiles/onepcm.dir/all] Error 2
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2


at the moment python3 is not supported. Python2 should be available.


If that’s the case, is there a compilation flag to tell ROOT to compile against a specific version of python?

I couldn’t figure out how to do this with compile options. I branched the git repository and modified all instances of /usr/bin/python to /usr/bin/python2.