Error in installing root 5.34.05

I am trying to install root v5.34.05 on my Ubuntu 17. I used the command
./configure --all
and then when I want to compile with “make” I get the following error.
Please help.

bin/rmkdepend -R -fcint/cint/src/dict/libstrm.d -Y -w 1000 -- -pipe -m64 -Wall -W -Woverloaded-virtual -fPIC -Iinclude   -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY  -I/home/dary/Desktop/root/cint/cint/inc -I/home/dary/Desktop/root/cint/cint/src -I/home/dary/Desktop/root/cint/cint/src/dict -pthread -Icint/cint/lib/libstrm -Icint/cint/lib/stream -I. -D__cplusplus -- cint/cint/src/dict/libstrm.cxx
g++ -O2 -pipe -m64 -Wall -W -Woverloaded-virtual -fPIC -Iinclude   -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY  -I/home/dary/Desktop/root/cint/cint/inc -I/home/dary/Desktop/root/cint/cint/src -I/home/dary/Desktop/root/cint/cint/src/dict -pthread -Icint/cint/lib/libstrm -Icint/cint/lib/stream -I. -o cint/cint/src/dict/libstrm.o -c cint/cint/src/dict/libstrm.cxx
In file included from cint/cint/src/dict/libstrm.h:37:0,
                 from cint/cint/src/dict/libstrm.cxx:14:
cint/cint/lib/stream/iostrm.h:24:10: fatal error: iostream.h: No such file or directory
 #include <iostream.h>
compilation terminated.
Makefile:594: recipe for target 'cint/cint/src/dict/libstrm.o' failed
make: *** [cint/cint/src/dict/libstrm.o] Error 1

I have had same problem. iostream.h was for old compiler. Usually start from scratch, especially making sure ROOTSYS is not set, will solve the problem. However after that I got segmentation fault when I create TBrowser :frowning:

problem not solved. still same error

what did you do after that. I still get the same error

Please try again with version 5.34/38. I believe the error above has been solved in later 5.34 releases.

I already tried 6 versions but not this one. I couldn’t find the download link, would you please give the download link?
actually there is no 5.34/38 in the list. but I already tried 5.34/36 and 5.34/34

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.