Error in gROOT->GetVersion()

Hi there. In trying to post a topic about the problem I am actually having, I tried to find my version of ROOT using gROOT->GetVersion() suggested in this post. However, I get the following errors.

root [0] gROOT->GetVersion()
Error in <TReentrantRWLock::WriteUnLock>: Write lock already released for 0x2a44128
Error in <TRint::HandleTermInput()>: std::runtime_error caught: locale::facet::_S_create_c_locale name not valid

Whenever I run root, I also receive the following warning but I’m not sure it its important.

Warning in <EnableImplicitMT>: Cannot enable implicit multi-threading with 0 threads, please build ROOT with -Dimt=ON

Any help would be greatly appreciated!

ROOT Version: I think it’s 6.22/02
Platform: Centos7
Compiler: I think it’s g++? How do I find out?


Can you tell us how you installed ROOT? Did you compile it yourself or does it come from a system package or the binary distribution?


Are you running in a virtual machine?

I installed root using yum install root, so I believe it’s from the Centos7 system package.

I am using a Windows Ubuntu subsystem to SSH to my computer at work which is running Centos7 natively.