Error accessing files over XRootD using CVMFS

I’m not sure if this is a ROOT problem, but I’m not sure where to ask otherwise, either.

I have a CVMFS stratum 0 server installed and a running version of ROOT 5 inside its repository. This root was built with the XRootD (3.3.6) feature enabled, following the instructions of the User Manual This worked flawlessly.

Now I have two clients, both accessing my CVMFS repository with ROOT. This works as well. I can compile and link against it.

Next I want to access some files on EOS, using XRootD. On one client, this is no problem. On the other, however, I get the error (whether or not I authenticated with Kerberos beforehand)

Plugin No such file or directory loading sec.protocol
Plugin No such file or directory loading sec.protocol

I did look for those libraries, but can’t find them anywhere. But that’s also true for the machine where EOS access works.

Because of the first missing library, I checked whether Kerberos access works. It does. The Kerberos configuration (/etc/krb5.conf) is identical on both clients and I can access lxplus using my Kerberos tokens just fine on both machines.

Both clients are running SLC 6 and have access to the same resources. They share the same ROOT from the CVMFS repository and thus the same XRootD. I even looked at a diff of the environment variables and they are identical, as well.

I am lost as to what could do to find the origin of this error. I even tried a local installation of ROOT on the client machine where XRootD is not working. This local installation works, so Kerberos is indeed functioning properly.

It could be a ROOT problem, an XRootD problem or a CVMFS problem or, of course–most probably–an error with my setup and I have no idea how to figure out which one it is. Do you have any ideas?

Thank you very much!


I am not (yet) seeing any direct implication for ROOT. Perhaps a good start could be an in-depth analysis of the differences between the two machines?


Maybe I should’ve made clear that I open the files with

when the aforementioned error occurs. I’m trying to find out which program (root or xrootd) is trying to load the missing libraries and where they are supposed to be located at, i. e. does the error message come from ROOT or XRootD? There is no in either ${ROOTSYS}/lib nor in the lib directory of XRootD. So either they are not needed or they are located locally on the machine but I wouldn’t know, where.