Du -sh . in an eos mounted directory reports double the actual disk usage

I’ve mounted my eos partition onto afs with eosmount eos.

To examine how much data is stored in one of my sub folders, I ran du -sh . in the appropriate folder.

When I copied this folder to my local machine for faster analysis, I did the same operation to make sure all data made it, and found that du -sh . returns half the value:

On lxplus:

mkrafczy on lxplus0094 [16:41:30] ~/eos/ams/user/m/mkrafczy/Jobs/EP_v14_small_v5/Reduced_Analysis/v1 ○ du -sh . 127G .

On my local machine:

matthew on Wagner [17:13:25] ~/AMSData/ProducedData/EP_v14_small_v5 ○ du -sh . 64G .

To make sure they weren’t actually different, I ran the following script on both lxplus and my local machine:

diffing the resulting md5sum_list.txt files from my local machine and lxplus show no difference, implying that they are indeed the same files, and that du -sh . is indeed reporting twice the used disk space on the eos mounted directory.

What is the reason for this?

I did du -sh without -h to get exact values, I have:

on lxplus:

mkrafczy on lxplus0094 [17:19:06] ~/eos/ams/user/m/mkrafczy/Jobs/EP_v14_small_v5/Reduced_Analysis/v1 ○ du -s . 132429393

on local machine:

matthew on Wagner [17:19:45] ~/AMSData/ProducedData/EP_v14_small_v5 ○ du -s . 66215104

double what my local machine has is 132430208 which is 815 bytes different from the lxplus result. So not exactly double, but very close.


you may want to try:

du --apparent-size

From the du manpage:


Excellent! That was it! Thanks!

mkrafczy on lxplus0078 [11:11:33] ~/eos/ams/user/m/mkrafczy/Jobs/EP_v14_small_v5/Reduced_Analysis/v1 ○ du -s --apparent-size . 66214714