`-Dtesting=OFF` flag not honored


I’m building ROOT 6.28.08 from source on a RHEL8 machine that has no access to internet resources outside CERN (the main reason is that the system’s precompiled package is for python3.6, but I need ROOT built for python3.8) and I face an issue similar to the one mentioned here, i.e. I get:

-- Could NOT find Git (missing: GIT_EXECUTABLE)

and a bit later:

CMake Error at /usr/share/cmake/Modules/ExternalProject.cmake:2633 (message):
  error: could not find git for clone of googletest                          

However, even when trying using -Dtesting=OFF:

cmake -DCMAKE_INSTALL_PREFIX=/data/srv/root /tmp/root -Dtesting=OFF -DPython3_ROOT_DIR=/usr/bin/python3 

I still get the same message.

I made sure that testing is disabled, by adding a message inside the CMakeLists.txt file:

  message(WARNING "!!")

Any idea why this fails?

Solved it by using -Dbuiltin_gtest=OFF.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.