Drop down menu not selectable

Hi -

I am running El Capitan with ROOT 5.34.32.

When a ROOT window displays, the cursor has trouble selecting a drop down menu.

I tried attaching a video showing the behavior, but .MOV extensions are not allowed. (What year is it?)

I’ve tried installing different Java versions, but it did not help.

To explain, if I want to turn on the “editor”, I can click “View” just fine, but when I try to select “Editor”, or ANY of the drop down menu items, they do not turn dark gray on hover, and clicking on them only closes the menu down.

By moving the cursor around a bunch of times, it will randomly become selectable.

The frustrating quirks of ROOT are bad enough without having to deal with something like this!

Any ideas?


Yes, see for example [url=https://root-forum.cern.ch/t/pop-up-menus-not-working-with-mac-os-el-capitan/19983/1 thread[/url]

Cheers, Bertrand.

Thank you, Bertrand.

Did I somehow miss something when I downloaded this precompiled binary of ROOT for OS X? Was it tested before release?

I did try to compile when I booted up my new Mac, but there was some other careless bug that prevented that from that from working. I settled for the binary because I assumed it would work.

I would kindly request more effort be placed on ensuring a functioning product for us out there trying to analyze data, so we don’t also have to waste our time getting our tools to even turn on. There is already so much wasted time reinventing the wheel with ROOT; and I apologize for the rudeness but it is exceedingly frustrating from the end user perspective that after all these years, there are only more problems.

And then what is the link you sent me? This is not helpful. It is just links to links to links. So now when someone finds my post, they are going to have to wade through more links to get the product they downloaded to work on the system it is supposed to have been designed to work on? I hope you understand my frustration.



Let me add my 2 cents as an end-user, I can certainly understand your frustration.

However, I know from personal experience how much El Capitan changed already in the way the libraries are dynamically loaded. Apple keeps doing this even more and more during the latest OS X releases.
Each time I need to adapt our analysis software to keep it at least working for our Mac OS X-using collaborators. These issues do not show up so much with any Linux distribution I ever encountered.

From this point of view, I must say it is a MAGNIFICIENT piece of work the ROOT team is doing - I would call an operating system which was released less than two months ago still very experimental, it is really not to be expected to be in production use yet, but ROOT already supports it!

So how can you expect a piece of software (ROOT 5.34.32) which was released in June 2015 to work perfectly out of the box on an OS released in September?

If you follow the links provided by Bertrand, you will find they directly direct you to the patch for ROOT 5 and ROOT 6 master which solves this issue, which you could also have found using the Search function of the forum (it’s now at least the third thread on this…).
If you read the patch messages, you will further find that they adapted to unknown (probably fully unannounced by Apple) changes in the depths of Quartz / Cocoa.
They did this less than a week after El Capitan was released - which meant they tested, found the problem, identified it and committed a change. There are not many other projects out there adapting to experimental OSes that fast (and yes, I consider an OS which is less than a month old and has undocumented changes not ready for production).

Again, yes, I understand your frustration, but please don’t put the blame on the ROOT team!