Drawing TH1 Always Shows Overflow

Hello there,

I’ve done a bunch of searching but it seems no one has this issue… I’m simply trying to draw a TH1 after rebinning+setting the axis ranges, and ROOT always draws the overflow bin, but not the underflow bin. I can’t convince it to not do this!

Is there a flag i can set somewhere to force it to NOT draw the overflow bin?

Thank you, cheers!

I guess you set the axis ranges so that they include the overflow bin. Try:

your_histo->GetXaxis()->SetRange(1, your_histo->GetNbinsX());

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.