Draw option "underlay"

Dear all,
if a TF1 is fitted to a TGraphErrors, the fit is overlayed on top of the data points (using “ap”, I dont want a line between data points).
I do a couple of fits to the same graph, and the data points get “hidden” by the fits.

Is there a way to “underlay” these fits? Or re-draw just the graph (and not the fits), such that the data points from the graph stay on top?

Cheers,
Hendrik

HEllo, do you use the “0” option in the Fit function? See the documentation.

TGraph *g = new TGraph(); TF1 *f = new TF1(...); ... g->Fit("f","0");

Hi.

option = “0” -> Do not plot the result of the fit.

I WANT the fits to be drawn, but NOT on top of the data, but on a lower layer, so to speak.
So the data stays on top of the fit.

Cheers,
Hendrik

Try:
graph->Fit(function, “0”); // fit without drawing
graph->Draw(“A*”); // draw “stars” AND axes
function->Draw(“SAME”); // draw the function
graph->Draw("*"); // re-draw “stars” on top

that works, thanks!