Does `TTree::SetMaxFileSize()` set the file size limit

I am aware of TTree::SetMaxFileSize() because recently i ran into TTree that is >100GB (i got Fill: Switching to new file: followed by a segmentation fault). the problem solved when I set the limit >100GB.

here’s are some related discussions:

however, i am getting the same error even with the TTree is well below the limit, but the TFile (contain tree and alot of TGraphErrors) is believed to be >100 GB.

i ‘verified’ the size of the tree by Print():

*Tree    :tree      : tree                                                   *
*Entries :    42089 : Total =        10480384 bytes  File  Size =    5423795 *
*        :          : Tree compression factor =   1.93                       *

My question is: does the limit of file is also set by TTree::SetMaxFileSize() ?

_ROOT Version:6.26.00
_Platform:conda (in Ubuntu 20.04, WSL)
_Compiler:GCC 10.4.0

@pcanal should be able to help you on this

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.