Display issues using Mac OS 10.5.5


I’ve searched the forums, but to no avail. I have installed root on my Mac running OS 10.5.5 and using the bash shell by:

  1. Downloading the binaries and installing.
  2. Downloading the source and compiling.

I tried the installation option 2 after I got this message when running root from the pre-compiled binary:

  *                                         *
  *        W E L C O M E  to  R O O T       *
  *                                         *
  *   Version   5.20/00      24 June 2008   *
  *                                         *
  *  You are welcome to visit our Web site  *
  *          http://root.cern.ch            *
  *                                         *

ROOT 5.20/00 (trunk@24524, Oct 02 2008, 14:37:00 on macosx64)

CINT/ROOT C/C++ Interpreter version 5.16.29, Jan 08, 2008
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] TBrowser b
Error in <TGClient::TGClient>: can't open display ":0.0", switching to batch mode...
 In case you run from a remote ssh session, reconnect with ssh -Y
root [1] 

But unfortunately, even after successfully compiling, I am still getting the same error. No matter what type of function I call (Creating a canvas, e.g.) I get an error if it involves anything to do with the display.

This is so fundamental an issue, that I don’t know where to start trying to figure out what is wrong. Even the splash screen on startup does not show up.

Any suggestions would be helpful.


Did you start the X11 server?


That did it. Thanks!

For others in the same situation, execute:

before trying to run root.