Disable drawing when fitting

My default, the Fit function comes with an input goption. I would like to fit something without drawing anything or creating a canvas.

When I try leaving the parameter blank
input_hist->Fit(“func_sig”,“QL”,"",lowin,highin);
I still get an empty canvas that pops up.

Is there a way to completely disable the drawing when you Fit something?

Use option “0” as described in the TH1::fit documentation
input_hist->Fit("func_sig","QL0","",lowin,highin);
Rene

thanks, that did the trick.