Difficulty installing ROOT on Intel Macbook w/ Leopard


I just formatted and installed Leopard on my Mac and am trying to get ROOT working again. I am hoping someone will be able to point out where I went wrong along the way.

I first installed Xcode 3.0
Following that, I installed gcc and g77 as on the website: hpc.sourceforge.net/

Leopard has X11 already installed, so I didn’t need to mess with that.

So I went to install ROOT, and I found the following…
When I installed via the Source, things would appear to install fine and I could run ROOT from the terminal. However, when I went to use the makefile for one of my programs (uses ROOT libraries), I get the error:
ld: library not found for -lCore

So I tried using the Binary, and I can’t even run ROOT from the terminal. When I type “root”, I get the following:
dyld: Library not loaded: /afs/.cern.ch/sw/lcg/external/pcre/4.4/osx104_ia32_gcc401/lib/libpcre.0.dylib
Referenced from: /Users/travismartin/root/lib/libCore.dylib
Reason: image not found

I took that to mean that there is an issue with my paths. I use bash, and my .bashrc file has the following:
export PATH=$PATH:./:/usr/local/bin/
export ROOTSYS=~/root
export PATH=$PATH:$ROOTSYS/bin

When I type “echo $PATH” or ROOTSYS or whichever, I do get the correct path returned to me.

So… I am hoping someone can see what I have wrong or see what the error is. I know ROOT works on Leopard. I originally just did an upgrade on my MacBook, but I wasn’t happy with the result (some things worked slowly and it just seemed cluttered and buggy). When I had just the upgrade, ROOT worked fine, though.

(Is it XCode 3.0 that is the problem maybe?)

As an addendum:
When installing from source, I used the commands:
export ROOTSYS=~/root
./configure macosx

(I am installing root to my home directory, where I had it before on Tiger.)

Here is the exact error when compiling from the source. I just installed XCode 2.5 and tried again. I can run ROOT command line style, but using the libraries doesn’t work, when I compile from source.

g++ -o data/zprime.exe -O -lg2c zprime.o coup.o dec.o pdf.o Cteq6Pdf-2004.o integrate.o rootset.o cross.o print.o rcuts.o hist.o thesis.o paper.o -L-L/Users/travismartin/root/lib -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lfreetype -pthread -lm -ldl -L/usr/local/lib
ld: library not found for -lCore
collect2: ld returned 1 exit status
make: *** [zprime.exe] Error 1

A friend of mine (unfamiliar with root) pointed out the following from when I try to compile:

And in my makefile I have:
ROOTLIBS = -L$(shell root-config --libs)

Which resolves simply as -L (apparently). So it seems that my libraries aren’t resolving…