Dictionary generation failed for TSelector class from MakeSelector

System Info:
Ubuntu 16.04.1 LTS
x86_64 GNU/Linux
gcc version 5.4.0 20160609
root 6.08/00

I have billions of events needed to be processed so I’m trying to use PROOF. Following the online tutorial,

  1. I use MakeSelector to generate a MySelector class from my root file, didn’t change anything.
.L MySelector.C+

Warning in : Failed to generate the dependency file for /media/sf_Xray/./MySelector_C.so
Error in : Dictionary generation failed!

Any idea what’s going on?

FYI, I try to run simple example as shown at root.cern.ch/processing-proof#prooffirst
failed. Same error, cannot generate dictionary.

Dear gjzeus,

I assume that you have writing rigths on /media/sf_Xray/ .
Can you load any of the selectors under $ROOTSYS/tutorials/proof or $ROOTSYS/tutorials/tree?
For example, what do you get from

 cd /media/sf_Xray/
 cp -rp $ROOTSYS/tutorials/tree/h1analysis.{C,h} .
 root -l
 .L h1analysis.C+


G Ganis

Yes. I can create, edit, delete in that directory. But it’s a shared folder. I use VBox in windows.

Under that directory, I cannot. I switch the directory to $HOME/Downloads, everything works fine. It seems the problem of ownership of the directory.
Now problem solved.
Thank you very much.