Cyrillic letters in root (Gui)

Dear all,
does anyone know how to use cyrillic characters in root in modern linux systems? In particular, I’m interested in cyrrilic letters in Gui (windows names, menus etc), but also for interactive root sessions it would be useful.
Currently I’m using Mint linux 17.1, but I suspect that similar problems should be with any linux system.

After searching this forum I found basically only one topic [url]Cyrillic letters in ROOT with a similar problem. Also, there are some other font related posts, e.g. [url]Adobe-helvetica-medium on Ubuntu 14.04

After all, it seems that the simplest solution should be replacing the string

Unix..Gui.DefaultFont: -adobe-helvetica-medium-r---12------iso8859-1


Unix..Gui.DefaultFont: -adobe-helvetica-medium-r---12------iso8859-5

in the .rootrc file. However, it doesn’t help in my case. Actually, I don’t understand how the fonts are managed in root/linux. Even when I replaced the font name by something like
Gui.DefaultFont: --non-existing-font**
there are no changes. No errors, no complains, and still bad characters in Gui.

Another solution, which was given in the first topic in 2005, was to use the QT layer with root (, but it seems to be rather complicated to me, as I’m not familiar with QT.


This will probably not work, but you could try to enable Xft (by setting “X11.UseXft: yes” in $(ROOTSYS)/etc/system.rootrc or in your custom $(HOME)/.rootrc file), and change the Unix.*.Gui.DefaultFont with a cyryllic TTF font.

Cheers, Bertrand.

Thanks for this hint, but I don’t understand how it should help. Yes, I could enable Xft (although I don’t understand what it means). But how to change the Unix.*.Gui.DefaultFont with a cyryllic TTF font?? How to change it with any font?

As I said, I can replace

Unix..Gui.DefaultFont: -adobe-helvetica-medium-r---12------iso8859-1


Gui.DefaultFont: --non-existing-font**

but nothing changes. The system doesn’t react on this line at all, although there is a clear mistake in it.

gEnv->Print() shows:
Gui.DefaultFont: --non-existing-font** [User]

I also don’t know where to find cyrillic TTF fonts. I installed xfonts-cyrillic, but I even don’t know where they are in my system and what are their names…


Hi Yuri,

Well, if you specify a non-existing font, ROOT will automatically select the default font.
Concerning Cyrillic fonts, I will make some tests next week and I’ll let you know how to make it working, if it is possible…

Cheers, Bertrand.