Creating shared Libraries for RALICE on Macintosh

ROOTers hi,

  I'm facing a problem. I have installed ROOT on my Mac (Operating system 10.3.3, "Panther"), and it runs fine. (':D')
  Next what I attempted to do is to install RALICE, and here's where I run into a problem.(':cry:')

I can not create shared libraries of the RALICE package using g++ on Mac. I need to create these shared libraries to load them into a ROOT session. When I run script ~/AliRoot/RALICE/gcclib - sh gcclib (gcclib is attached - courtesy of Nick van Eijndhoven), the shared libraries are not created. Mac gcc compiler has not the option -shared; it worked on installing ROOT fine, and on gcc -v I get:

“Reading specs from /usr/libexec/gcc/darwin/ppc/3.3/specs
Thread model: posix
gcc version 3.3 20030304 (Apple Computer, Inc. build 1495)”

I would think that it is a compiler which causes a problem - therefore I think I need:
List of compiler options I have to use, and
Any C++ class/patch for creating shared libraries with.

Needless to say, I’dd appreciate your help indeedy. Being novice in all this ROOT/compiler/shared business (mainly Mac user) I beforehand apologize if my problem sounds stupid/trivial, but nevertheless I appreciate your help.

George Japaridze (’:D’)


From you description, gcclib has not been ported to Mac. You can check how the ROOT libs have been build by looking at the log of the gmake or by looking in $ROOTSYS/config/Makefile.macosx