Hi, when I start my program on my computer I receive this error message:

There was a crash.
This is the entire stack trace of all threads:

#0 0x00007f6ae916f64a in __GI___waitpid (pid=5533, stat_loc=stat_loc
entry=0x7fff8f5fd680, options=options
entry=0) at …/sysdeps/unix/sysv/linux/waitpid.c:29
#1 0x00007f6ae90e8fab in do_system (line=) at …/sysdeps/posix/system.c:148
#2 0x00007f6aeaf90dd4 in TUnixSystem::StackTrace() () from /usr/lib/x86_64-linux-gnu/
#3 0x00007f6aeaf9303c in TUnixSystem::DispatchSignals(ESignals) () from /usr/lib/x86_64-linux-gnu/
#5 0x00007f6ae87d269d in G__destroy_upto () from /usr/lib/x86_64-linux-gnu/
#6 0x00007f6ae87d34bc in G__scratch_globals_upto () from /usr/lib/x86_64-linux-gnu/
#7 0x00007f6aeaf524b0 in TCint::ResetGlobals() () from /usr/lib/x86_64-linux-gnu/
#8 0x00007f6aeaed463f in TROOT::Reset(char const*) () from /usr/lib/x86_64-linux-gnu/
#9 0x000000000040143f in main () at

The crash is most likely caused by a problem in your script.
Try to compile it (.L myscript.C+g) and fix any errors.
If that does not help then please submit a bug report at Please post the ENTIRE stack trace
from above as an attachment in addition to anything else
that might help us fixing this issue.

But, when I start same program it on another computer it works perfectly.
Can you please help me?
Thank you!

What is the difference between the computers?
Can you attach a minimal reproducer of the problem?


I do not know what is difference. Since it was not working on my computer I tried to run it on colleague’s one and it was working properly.

Can you attach a minimal reproducer of the problem?

I attached .cc file.
I use this code to make executable file T1.e:


OBJS = (patsubst, %.o, (SOURCEFILES))

ROOTCFLAGS := (shell root-config --cflags) ROOTLIBS := (shell root-config --libs)
ROOTGLIBS := $(shell root-config --glibs)


g++ -Wall {CFLAGS} -c -g -o @ $<

g++ -Wall -o @ (OBJS) (LDFLAGS) (LIBS) -lGeom


-rm -f {PROGNAME} {OBJS}

And then when I run it, I receive mentioned error message (26 KB)

And data file is attached here…
b10-136.root (659 KB)


Remove the call to ‘gROOT->Reset();’ which should not be used within a function except in rare case and require the setting to be ‘more’ setup than it is at the very beginning of main.


It is working now! :slight_smile:
Thank you very much.