Crash in Root build

I tried to build root 6.14 on OpenSuse 15.0. The build dies with

[ 75%] Built target BaseTROOT
make[2]: *** No rule to make target 'lib/libpcre.a', needed by 'lib/'.  Stop.
make[1]: *** [CMakeFiles/Makefile2:15707: core/CMakeFiles/Core.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Has anybody seen this already and can help me?

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

The information above is not sufficient to diagnose what the problem is. My guess is that the builtin libpcre failed to configure or build. I recommend installing it in the system instead of enabling the builtin version. You can try installing the list of packages for CentOS 7 from this file to get all dependencies ROOT needs. To enable support for all of it, just configure with cmake -Dall=ON $srcdir.

Thanks for your help. I attach a screenshot from yast searching for pcre. The ticked packages are what is installed. Am I missing something?

Please try reconfiguring cmake to use the system library now with cmake . -Dbuiltin_pcre=OFF. I think you are not missing anything, only pcre-devel is sufficient as far as I know from the list above.

Thanks! This solved the problem.



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.