Cppyy user-side breaks ROOT

Hi! Installing a user-side cppyy (no virtualenv) breaks the python based ROOT tools.
While it’s expected, i was wondering if, given the special local only usage of a private/local version of cppyy, if this could be encapsulated somehow, so ROOT would use only it’s own version in such a way that is does not see any other cppyy version (even if discovered), and also the private cppyy modules are put in a place that would not be seen by anything outside ROOT as it’s not usable anyway:

[Thursday 06.04.23 21:38 adrian@hal] ~ $
Python 3.11.2 (main, Feb  8 2023, 00:00:00) [GCC 12.2.1 20221121 (Red Hat 12.2.1-4)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import cppyy
/usr/lib64/python3.11/site-packages/cppyy_backend/loader.py:90: UserWarning: No precompiled header available (/usr/lib64/python3.11/site-packages/cppyy_backend/etc not writable); this may impact performance.
  warnings.warn('No precompiled header available (%s); this may impact performance.' % msg)
/usr/lib64/python3.11/site-packages/cppyy/__init__.py:266: UserWarning: CPyCppyy API path not found (tried: /usr/include); set CPPYY_API_PATH to fix
  warnings.warn("CPyCppyy API path not found (tried: %s); set CPPYY_API_PATH to fix" % os.path.dirname(cpycppyy_path))

Thank you!

Hi @adrian_sev!

There is no solution to this problem yet, and one reason for this is also that we don’t understand the problem enough. Also, the PyROOT maintainers are currently on vacation, so it would be better if you create a GitHub improvement request about this problem so it is not forgotten:

If you could write the same content in the issue as in this forum post that would already be great, but in addition to that, can I ask your to explain how the problem of cppyy breaking ROOT can be reproduced step by step for the developers? Like how did you install which versions of these packages, and which Python script do you have to run to get the errors.

Thank you very much!

Thanks for reply! Done Cppyy user-side breaks ROOT · Issue #12635 · root-project/root · GitHub

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.