Compiling script

This is a very basic question, but here goes:

I’m trying to compile my script before running it so it runs faster by using “.x script.c+(##)”, but i keep getting the message : “rootcint: option -c must come directly after the output file
Error: script(##)output Syntax error? FILE: LINE:0” What am i doing wrong? I’ve tried all combinations of lower case and capital x, and one and two plus signs, but same error always. Does my script have to be in teh macro folder of the root directory, even though it doesn’t if your just interpreting it? Thanks alot for your help!


forgot to mention that the script works fine when interpreted only: “.x script.c(##)”

Hi Paul,

Your forgot to mention which version of ROOT you are using and on which platform.

When you say:

Do you mean the pound sign literally?
If you don’t what do you really put there.
If you do, what is the intent?


I’m using ROOT-3.02 on a linux machine. The pound sign is where the run number that the script is processing goes, and is extracted in the script via argv[].



Try to rename your script with .cxx instead of .c.

If this does not solve the problem, please send enough information (a complete tar file for example) to reproduce the problem.


That seemed to do the trick. Now the only errors are from my crummy programming. Thanks alot!