Compiling Root 6.02.00 under Mac OS X Yosemite?


I made a mistake of upgrading to Mac OS X Yosemite beta version, and root stopped working on my machine. I tried to compile the 6.02.00 version of root but can’t get it compiled or linked due to missing “assert.h” file

I used

./configure macosx64 --with-macosxvers=10.9

to compile as otherwise the config script doesn’t find the Xcode SDK (since there is no 10.10 update yet).

Has anyone succeeded in compiling the Root 6 (or an earlier version) under Yosemite, and if so, is it possible to download a binary installation?




I managed to build ROOT 6 on 10.10. You are likely missing the command line tools; xcode-select --install might help.

Cheers, Axel.

Thanks, Axel!

Indeed, doing what you proposed (plus downloading the Xtools for Yosemite from the developer site) worked!

Now I can run root, but I face a different problem (previously reported here, but with no solution).

I can load and execute C++ macros in interpeter mode, i.e.:


However, when I do


to run in the compiled mode, the compilation goes fine, but when it builds the library I always get:

ld: cannot link directly with /usr/lib/libextension.dylib for architecture x86_64

although I have this library:

-rwxr-xr-x 1 root wheel 261648 9 9 19:15 /usr/lib/libextension.dylib*

Any ideas on how I could overcome this problem?



Hi Greg,

Thanks, I’m checking what’s up with

I’ll let you know.


It’s fixed in the master and 6-02-00-patches. Thanks for your report!

Cheers, Axel.