CompilerVersion of binary distribution

Windows 10, x64, root_v6.24.06

Dear people,

I had installed 6.24.06 using downloaded binary distribution. After running root, I’ve tried gSystem->GetBuildCompiler() and get the next answer:
(const char *) “C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.23.28105/bin/Hostx64/x86/cl.exe”.
For gSystem->GetBuildCompilerVersion() i have:
(const char *) “MSVC 19.23.28107.0”.

But I have only 14.26.28801 and 14.27.29110 MSVC. 14.23.28105 and 19.23.28107.0. is the version that was used in building of this binaries? Will I have any problems with this?


It depends on what you want to do. In principle, the same version is required, at least if you want to link with the ROOT libraries. But if it works on the command prompt, as it apparently does, just go ahead!

I ask because I have some problems. I tried to use Aclic, because I want create a shared library, but errors occurred. I decided that this is because of different versions of my MSVC compiler and the one that was used for building root binaries.
As i understand, i should install compiler version of downloaded binaries before installing root if I want to use Aclic, right?

P.S. I tried the downloaded binaries because I have problems with building root from source on Windows that I can’t solve (for example, a lot of errors “Wno-module-import-in-extern-c”).

Right, if you want to use ACLiC, then you need the same version of the compiler. And what was the problem when building from source? This should be straightforward.

Thanks for the answer.

P.S. perhaps i create another topic about problems with building root from source on Windows.