Compile root with apple M1max

Hi all,
I am using apple M1max. I am trying to install root6.24 with python following this guide
Building ROOT from source - ROOT
When I tried “cmake --build . – -j10”, there is an error like:

CMake Error at /Users/xin/onedrive/program/physics/tools/rootmax/XROOTD-prefix/src/XROOTD-stamp/XROOTD-build-Release.cmake:49 (message):
Command failed: 2

See also

Here is the log link:
root_error – Google Drive

Could you please take a look, thank you very much!


Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Never saw this… Do you actually need to build yourself? If not, you could just take a nightly build from here: Index of /download/nightly

I have created - it would be great if you could subscribe to that issue, and provide the info that they might need to fix this!


Could let us know which version of xrootd are you using, the offending code has been removed in

If I remember correctly this has been released in xxrootd 5.1.0.

You can alternatively just post your CMakeCache.txt from the build directory. I suspect that building v6-26-00-patches (or just grabbing the nightly build from Index of /download/nightly ) will solve this.

Thank you very much! Actually, I ever tried a nightly build while after installation I could not find where is the root file executable.
Yes, I have subscribed it on github.

Actually, I did not check the xrootD version. But I used the lastest root source file where the xrootD built in after cmake.

If you download the tar file, check the web on how that works.
If you download and installed it’s somewhere in /Applications/ROOT... - should be possible to find :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.