Compilation on power8

I’m trying to compile root6 on power8 linux system with ubuntu little endian.

First of all I have tried to remove some options:

cmake … -DCMAKE_INSTALL_PREFIX=$PWD -Dxrootd=OFF -Dbonjour=OFF -Dkrb5=OFF -Dssl=OFF -Dpgsql=OFF -Dpython=OFF -Dmysql=OFF -Dodbc=OFF -Dsqlite=OFF -Dldap=OFF

– Found GCC. Major version 4, minor version 8
– Found a 64bit system
– Found GNU compiler collection
– ROOT Platform: linux
– ROOT Architecture: linuxx8664gcc
– Build Type: RelWithDebInfo
– Compiler Flags: -pipe -m64 -Wall -W -Woverloaded-virtual -fPIC -pthread -std=c++11 -Wno-deprecated-declarations
– Looking for ZLib
– Looking for Freetype
– Looking for PCRE
– Looking for LZMA
– Found LZMA includes at /usr/include
– Found LZMA library at /usr/lib/powerpc64le-linux-gnu/
– Looking for X11
– Looking for GSL
– Looking for OpenGL
– Looking for Graphviz
– Looking for LibXml2
– Looking for FFTW3
– Enabled support for: asimage astiff builtin_afterimage builtin_ftgl builtin_glew builtin_llvm cxx11 cling exceptions explicitlink fftw3 fortran gviz genvector mathmore memstat opengl shadowpw shared thread tmva xft xml x11
– Target triple: x86_64-unknown-linux-gnu
– Native target architecture is X86
– Threads enabled.
– Doxygen disabled.
– Sphinx disabled.
– Building with -fPIC
– Constructing LLVMBuild project information
– Targeting X86
– Clang version: 3.6.0
– Could NOT find Subversion (missing: Subversion_SVN_EXECUTABLE)
– Configuring done
– Generating done
– Build files have been written to: /home/user1/source/root_v6/rootab/3/root-6.02.01/work

The first problem is that the system is recognized as an x86. In any case I have tried to compile it. It seems that clang and others compile

ls bin
genreflex memprobe proofserv rootcint rootcling rootcling_tmp root-config roots setxrd.csh thisroot.csh

but I get the following error:

[ 48%] Generating G__Net.cxx, ../../lib/libNet_rdict.pcm, ../../lib/libNet.rootmap
cd /home/user1/source/root_v6/rootab/3/root-6.02.01/work/net/net && ../../bin/rootcling -rootbuild -f G__Net.cxx -s /home/user1/source/root_v6/rootab/3/root-6.02.01/work/lib/ -rml -rmf /home/user1/source/root_v6/rootab/3/root-6.02.01/work/lib/libNet.rootmap -c -DR__NO_CRYPTO -I/home/user1/source/root_v6/rootab/3/root-6.02.01 -I/home/user1/source/root_v6/rootab/3/root-6.02.01/work/include NetErrors.h TSQLColumnInfo.h TServerSocket.h TFileStager.h TApplicationServer.h TWebFile.h TUDPSocket.h TNetFile.h TFTP.h TPServerSocket.h TApplicationRemote.h TPSocket.h TGridResult.h TGridJobStatus.h TSocket.h TSQLStatement.h TSQLMonitoring.h TGrid.h TSQLTableInfo.h TMessage.h TGridJob.h TNetFileStager.h TMonitor.h TSQLResult.h TGridCollection.h TGridJDL.h TGridJobStatusList.h RRemoteProtocol.h TSQLServer.h TSecContext.h TSQLRow.h TParallelMergingFile.h /home/user1/source/root_v6/rootab/3/root-6.02.01/net/net/inc/LinkDef.h
Error in <UnknownClass::ReadFile>: no file name specified
*** stack smashing detected ***: ../../bin/rootcling terminated
make[2]: *** [net/net/G__Net.cxx] Error 134
make[2]: Leaving directory `/home/user1/source/root_v6/rootab/3/root-6.02.01/work'
make[1]: *** [net/net/CMakeFiles/G__Net.dir/all] Error 2
make[1]: Leaving directory `/home/user1/source/root_v6/rootab/3/root-6.02.01/work'
make: *** [all] Error 2

Do you have any idea?

Thanks in advance

Hi Andrea,

is Net the only dictionary failing?
Would it be possible to run the dictionary generation command in gdb and see the stack trace?
I have never seen a stack smash being issued by rootcling before.



We do not support PowerPC yet; see

I expect that we will add PPC as supported architecture next year, after the migration to MCJIT.

Cheers, Axel.