Compilation error due to non-access to AliROOT librairies

Hi everybody,

here is my problem:

I am running a script:


aliroot -q "main.C++(\"arbores00.txt\")" &

which compiles a macro with ACLIC and is supposed to run it. In my macro (main.C), I use a personal class, which has been generated by a MakeClass(). As I compile the macro main.C with ACLIC, I include the class header in the macro. Where the header starts by:

#ifndef ClassArbore_h
#define ClassArbore_h

#include <TROOT.h>
#include <TChain.h>
#include <TFile.h>
#include <TLorentzVector.h>
#include <AliESDtrack.h>

// Header file for the classes stored in the TTree if any.
#include <TObject.h>
// Header for TMVA reader to compute the MVA response
#include "TMVA/Reader.h"
#include "TMVA/Tools.h"

class ClassArbore {
public :
   TTree          *fChain;   //!pointer to the analyzed TTree or TChain

But when it comes to this header, the compilation fails due to the AliESDtrack.h header, while I also use root libraries (TFile,TLorentzVector,…) whose do not crash.
The error message is the following:

Processing main.C++("arbores00.txt")...
I-TUnixSystem::ACLiC: creating shared library /home/alex/workstation/mytask/PbPb/reducedtask/tree_reader_test/TTree_example/./
In file included from /home/alex/workstation/mytask/PbPb/reducedtask/tree_reader_test/TTree_example/./main.C:5:0,
                 from /tmp/rootcint_0OepFj.h:3,
                 from /tmp/tHnMBa_cint.cxx:1:
./ClassArbore.h:15:25: fatal error: AliESDtrack.h: No such file or directory
 #include <AliESDtrack.h>

Do I have to include a path to one of my environment variable?
Or is the problem from somewhere else?

Thanks for your help,
ClassArbore.h (15.3 KB)
main.C (736 Bytes)
ClassArbore.cxx (62 KB)

Hi Alex,

I believe you didn’t set up the environment for the ALICE software properly. Maybe you can get the required instructions asking on the ALICE mailing lists: … pport.html


Does not seem so :frowning: I have tried to run it on different computers, with AliROOT installed in different ways, I still have the same error message.
But you are right, as it is specific, it might be better to ask an e-group.


A workaround is to write in your rootlogon.C the following: