Compatibilities of ROOT and Pythia8 version

Dear Experts,

Here we are facing very frequently problems related to the version incompatibilities between ROOT and Pythia8. We tried latest versions of Pythia and old one (Pythia8153) along with older versions of ROOT (6.34.36). May i get a list of compatibilites of both of these.
How can i run example of Pythia8 with root from rootexample in pythia8153 or $ROOTSYS/tutorials/pythia/pythia8.C

please can you guide me. thanks


ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided


You do not provide your OS, usecase or the way you build/link your packages, so what I say may not be 100% useful.

I provide ROOT and Pythia8 for ArchLinux and have found that there is a circular dependency. You need to build Pythia8 without ROOT and install it. Then build ROOT with Pythia8 and install it. Finally, rebuild Pythia8 with ROOT and install it. After that all should work.

Moreover, you need a couple of more locations in your path to make all the things work:

$ cat /etc/profile.d/
export PYTHIA8=/usr
export PYTHIA8DATA=$PYTHIA8/share/Pythia8/xmldoc


$ cat /etc/profile.d/
if [ $PYTHONPATH ]; then
    if [[ ":$PYTHONPATH:" == *":/usr/lib/root:"* ]]; then
        return 0;
        export PYTHONPATH=$PYTHONPATH:/usr/lib/root;
    export PYTHONPATH=/usr/lib/root;

with the paths substituted to match your installation, of course. Then you need to re-login or source those scripts manually to make the changes work.

After that you should be able to use Pythia8 and ROOT together.

However, that particular tutorial script you mentioned for me has a bug - it loads the Pythia8 interface, sets up a few things, works through the configuration and then segfaults. I’m guessing the tutorial script is outdated. So you should try testing on something newer.

EDIT: Yeah, it seems the example you mention is written for Pythia6. Maybe look how this package is built - Pythia6 and do the equivalent installations.


I am not aware of incompatibilities of ROOT with certain Pythia8 versions.

I am aware of what seems to be a bug in Pythia 8.235, causing crashes due to uninitialized data. I am reporting those to the authors of Pythia.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.